Вопрос задан 20.02.2019 в 20:37. Предмет Информатика. Спрашивает Крупская Надежда.

Написать программу площадь равнобедренной трапеции на паскале

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Саубетов Дамир.
Var 
a,b,h,s:real;
begin
readln(a,b); // нижнее, верхнее основание
readln(h); // высота 
s:=((a+b)/2)*h;
writeln(s);
end.


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа для вычисления площади равнобедренной трапеции на языке Pascal может выглядеть следующим образом:

``` program TrapezoidArea;

var a, b, h, area: real;

begin // Ввод значений оснований и высоты трапеции writeln('Введите значение первого основания: '); readln(a); writeln('Введите значение второго основания: '); readln(b); writeln('Введите значение высоты трапеции: '); readln(h); // Вычисление площади трапеции area := (a + b) * h / 2; // Вывод результата writeln('Площадь равнобедренной трапеции: ', area); readln; end. ```

В этой программе мы объявляем переменные `a`, `b`, `h` и `area` типа `real` для хранения значений оснований, высоты и площади трапеции соответственно.

Затем мы запрашиваем у пользователя значения первого и второго оснований, а также высоты трапеции с помощью функции `readln`.

Далее мы вычисляем площадь трапеции по формуле `(a + b) * h / 2` и сохраняем результат в переменную `area`.

Наконец, мы выводим результат на экран с помощью функции `writeln`.

Программа останавливается, пока пользователь не нажмет клавишу Enter с помощью функции `readln`.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос