Вопрос задан 20.02.2019 в 08:18.
Предмет Информатика.
Спрашивает Шабельникова Валерия.
Составить программу нахождения чисел от -100 до 100 кратных 7 pascal abc
Ответы на вопрос
Отвечает Сарафанников Константин.
Я взяла числа по модулю, иначе будет 0. Если тебя устраивает 0, тогда не пиши abs в условии.
var s,a: integer;
i:integer;
begin
a:=-101;
for i:=1 to 200 do begin
a:=a+1;
if a mod 7=0 then s:=s+abs(a);
end;
writeln (s);
end.
Выводит: 1470
var s,a: integer;
i:integer;
begin
a:=-101;
for i:=1 to 200 do begin
a:=a+1;
if a mod 7=0 then s:=s+abs(a);
end;
writeln (s);
end.
Выводит: 1470
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Программа на Паскале для нахождения чисел от -100 до 100, кратных 7, будет выглядеть следующим образом:
``` program FindMultiplesOfSeven;
var i: Integer;
begin for i := -100 to 100 do begin if i mod 7 = 0 then writeln(i); end; end. ```
В этой программе используется цикл `for`, который перебирает все числа от -100 до 100. Внутри цикла проверяется, кратно ли текущее число 7 с помощью оператора `mod`, который возвращает остаток от деления. Если остаток равен 0, то число кратно 7, и оно выводится на экран с помощью процедуры `writeln`.
Таким образом, программа будет выводить все числа от -100 до 100, которые делятся на 7 без остатка.
Топ вопросов за вчера в категории Информатика
Информатика 437
Информатика 11
Информатика 10
Информатика 44
Информатика 23
Информатика 43
Информатика 63
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
