Напишите программу печатающую номера элементов массива больших 30 (Паскаль)
Ответы на вопрос
var arr: array[1..50] of Integer;
i: Integer;
begin
randomize;
for i:=1 to 50 do
arr[i]:= random (100);
for i:= 1 to 50 do
begin
if arr[i] > 30 then
writeln ('Array[', i, '] = ', arr[i]);
end;
end.
Вот пример программы на языке Паскаль, которая выводит номера элементов массива, которые больше 30:
```pascal program PrintNumbers; const SIZE = 10; // размер массива var arr: array[1..SIZE] of Integer; i: Integer; begin // заполняем массив случайными числами Randomize; for i := 1 to SIZE do arr[i] := Random(100); // случайное число от 0 до 99 // выводим номера элементов больше 30 for i := 1 to SIZE do begin if arr[i] > 30 then WriteLn('Номер элемента ', i, ': ', arr[i]); end; end. ```
Программа начинается с объявления константы SIZE, которая определяет размер массива. Затем объявляется массив arr с использованием константы SIZE.
Далее, с помощью цикла for и функции Randomize заполняется массив arr случайными числами от 0 до 99.
Затем, с помощью еще одного цикла for, происходит перебор элементов массива. Если элемент больше 30, то программа выводит его номер и значение.
Вышеуказанная программа выводит номера элементов массива, которые больше 30. Если вам нужно вывести только значения элементов, то достаточно заменить строку `WriteLn('Номер элемента ', i, ': ', arr[i]);` на `WriteLn(arr[i]);`.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
