Вопрос задан 19.02.2019 в 06:54. Предмет Информатика. Спрашивает Коновалова Софья.

Написать ПРОГРАММУ и составить БЛОК СХЕМУ по этим задачам: 1)Дан массив из десяти целых чисел.

Определите, сколько элементов этого массива имеют максимальное значение. 2)В классе 20 учеников писали диктант по русскому.Написать программу и блок-схему подсчета кол-во оценок 2 3 4 5 получивших за диктант(писать через массив). 3)Объявлен набор в школьную баскетбольную команду.Известен рост каждого из n учеников желающих попасть в эту команду. Составьте алгоритм подсчета и блок схему количества претендентов имеющих шанс попасть в команду если рост игрока команды должен быть не менее 170 см.Запишите на языке Паскаль программу.Считайте рост претендентов случайным числом из диапазона 150-200 см, а число претендентов n=50.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Шестакова Ксения.
{ 1) Дан массив из десяти целых чисел. Определите, сколько элементов этого массива имеют максимальное значение. }
const n=10;
var 
  i,m,k: integer;
  var a: array[1..n] of integer;
begin
  m:=-1;
  writeln ('Исходный массив');
  for i:=1 to n do begin
    a[i]:=random(10);
    write (a[i]:3);
    if a[i]>m then m:=a[i];
  end;
  k:=0;
  for i:=1 to n do begin    
    if a[i]=m then k:=k+1;
  end;
  writeln;  
  writeln ('k = ',k);  
end.
--------------------------------------
Исходный массив
  0  9  6  1  2  9  6  7  4  7
k = 2
====================================

{ 2) В классе 20 учеников писали диктант по русскому. Написать программу и блок-схему подсчета кол-во оценок 2 3 4 5 получивших за диктант }
const n=20;
var 
  i,k2,k3,k4,k5: integer;
  var a: array[1..n] of integer;
begin
  k2:=0; k3:=0; k4:=0; k5:=0;
  writeln ('Массив оценок:');
  for i:=1 to n do begin
    a[i]:=random(2,5);
    write (a[i]:3);
    if a[i]=2 then k2:=k2+1 else
      if a[i]=3 then k3:=k3+1 else
        if a[i]=4 then k4:=k4+1 else k5:=k5+1;
  end;
  writeln;  
  writeln ('двоек = ',k2); 
  writeln ('троек = ',k3); 
  writeln ('четверок = ',k4); 
  writeln ('пятерок = ',k5); 
end.
------------------------------------
Массив оценок:
  4  4  4  3  5  2  2  4  4  3  4  4  4  4  4  3  4  4  4  3
двоек = 2
троек = 4
четверок = 13
пятерок = 1
============================================

{ 3)Объявлен набор в школьную баскетбольную команду. Известен рост каждого из n учеников желающих попасть в эту команду. 
Составьте алгоритм подсчета и блок схему количества претендентов имеющих шанс попасть в команду если рост игрока команды должен быть не менее 170 см.Считайте рост претендентов случайным числом из диапазона 150-200 см, а число претендентов n=50. }
const n=50; r=170;
var 
  i,k: integer;
  var a: array[1..n] of integer;
begin
  k:=0;
  writeln ('Массив - Рост претендентов:');
  for i:=1 to n do begin
    a[i]:=random(150,200);
    write (a[i]:5);
    if a[i]>=r then k:=k+1;
  end;
  writeln;  
  writeln ('Шанс попасть в команду имеют ',k,' претендентов');  
end.
------------------------------------------------
Массив - Рост претендентов:
 196  177  196  169  153  167  157  163  165  166  191  195  158  200  160  189  180  157  181  163  181  152  173  181  186  195  183  155  181  190  168  193  200  167  192  161  167  155  199  160  183  191  159  172  199  183  156  158  186  186
Шанс попасть в команду имеют 28 претендентов
===========================================
0 0
Отвечает Кондратьева Елизавета.
1)
var
  a: array[1..10] of integer;
  m, i,s: integer;

begin
  randomize;
  for i := 1 to 10 do 
  begin
    a[i] := random(+10) + 1;
    if a[i] > m then m := a[i];
  end;
  for i := 1 to 10 do 
  begin
    if a[i]=m then s:=s+1;
  end;
  writeln(s);
end.
Остальные не знаю,сори
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Решение задачи 1: Определение количества элементов с максимальным значением в массиве

Для решения этой задачи мы можем использовать следующий алгоритм:

1. Находим максимальное значение в массиве. 2. Считаем количество элементов в массиве, равных максимальному значению.

Программа на языке Паскаль:

```pascal program MaxValueCount; var arr: array[1..10] of integer; // массив из 10 целых чисел maxVal, count, i: integer; begin // инициализация массива (значения могут быть введены с клавиатуры или сгенерированы случайным образом) // ...

maxVal := arr[1]; // предположим, что первый элемент массива - начальное максимальное значение count := 1; // начальное количество элементов с максимальным значением

for i := 2 to 10 do begin if arr[i] > maxVal then begin maxVal := arr[i]; count := 1; // обновляем количество элементов с максимальным значением end else if arr[i] = maxVal then begin count := count + 1; // увеличиваем количество элементов с максимальным значением end; end;

writeln('Количество элементов с максимальным значением: ', count); end. ```

Блок-схема:

``` [Начало] | V [Инициализация переменных] | V [Установить начальное максимальное значение и количество] | V [Цикл по элементам массива] | V [Если текущий элемент больше максимального] | V [Обновить максимальное значение и количество] | V [Иначе если текущий элемент равен максимальному] | V [Увеличить количество] | V [Конец цикла] | V [Вывести количество элементов с максимальным значением] | V [Конец] ```

Решение задачи 2: Подсчет количества оценок за диктант

Для решения этой задачи мы можем использовать массив для хранения оценок и подсчитать количество каждой оценки.

Программа на языке Паскаль:

```pascal program DictationScores; var scores: array[1..20] of integer; // массив из 20 оценок count2, count3, count4, count5, i: integer; begin // инициализация массива (оценки могут быть введены с клавиатуры или сгенерированы случайным образом) // ...

count2 := 0; count3 := 0; count4 := 0; count5 := 0;

for i := 1 to 20 do begin case scores[i] of 2: count2 := count2 + 1; 3: count3 := count3 + 1; 4: count4 := count4 + 1; 5: count5 := count5 + 1; end; end;

writeln('Количество оценок "2": ', count2); writeln('Количество оценок "3": ', count3); writeln('Количество оценок "4": ', count4); writeln('Количество оценок "5": ', count5); end. ```

Решение задачи 3: Подсчет количества претендентов в баскетбольную команду

Для решения этой задачи мы можем использовать следующий алгоритм:

1. Считываем рост каждого претендента. 2. Подсчитываем количество претендентов с ростом не мен

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос