 
. Написать программу, которая считывает в окне консоли целое число n и используя Math.random()
печатает в окно консоли n случайных чисел между 0 и 1, а затем печатает их среднее значение. Использовать while и псевдокод. плз ребята. в еклипсе 0
        0
         0
        0
    Ответы на вопрос
 
        i = 0
s = 0
while i<n do
i += 1
r = Math.random(0,1)
s += r
puts r
end
puts s/n
 0
                    0
                     0
                    0
                 
            Программа на Java, которая реализует данную задачу, может выглядеть следующим образом:
```java import java.util.Scanner;
public class RandomNumbers { public static void main(String[] args) { Scanner scanner = new Scanner(System.in); System.out.print("Введите целое число n: "); int n = scanner.nextInt(); double sum = 0; int count = 0; while (count < n) { double randomNumber = Math.random(); System.out.println(randomNumber); sum += randomNumber; count++; } double average = sum / n; System.out.println("Среднее значение: " + average); } } ```
Этот код сначала считывает целое число `n` из консоли, затем в цикле использует `Math.random()` для генерации `n` случайных чисел между 0 и 1. Каждое сгенерированное число выводится в консоль, а также добавляется к сумме `sum`. После этого программа вычисляет среднее значение `average` как сумму всех сгенерированных чисел, деленную на `n`, и выводит его в консоль.
Чтобы запустить эту программу в Eclipse, создайте новый проект, добавьте новый класс с именем `RandomNumbers` и скопируйте код в метод `main`. Затем запустите программу, введя целое число `n` в окне консоли.
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			