Уровень C. Введите массив с клавиатуры и найдите (за один проход) количество элементов, имеющих
максимальное значение. Пример: Массив: 3 4 5 5 3 4 5 Максимальное значение 5 Количество элементов 3Ответы на вопрос
mas: array[1..7] of integer;
k, i, MAX:integer;
Begin
for i:=1 to 7 do
Begin
writeln('Введите число');
readln(mas[i]);
end;
MAX:=mas[1];
k:=1;
for i:=2 to 7 do
Begin
if mas[i] > MAX
then
Begin
MAX:=mas[i];
k:=1;
end
else
if MAX=mas[i]
then k:=k+1;
end;
writeln();
writeln('Максимальное значение = ', MAX);
writeln('Количество элементов = ', k);
readln();
end.
Задача
Вам необходимо написать программу на языке C, которая позволит пользователю ввести массив с клавиатуры, а затем найдет количество элементов, имеющих максимальное значение.Решение
Для решения этой задачи можно использовать следующий алгоритм:1. Создайте переменную `max_value` и инициализируйте ее значением первого элемента массива. 2. Создайте переменную `count` и инициализируйте ее значением 1, так как первый элемент уже имеет максимальное значение. 3. Считайте массив с клавиатуры и сохраните его элементы в массиве `arr`. 4. Проходите по массиву `arr` со второго элемента до конца. - Если текущий элемент больше `max_value`, обновите `max_value` и сбросьте значение `count` на 1. - Если текущий элемент равен `max_value`, увеличьте `count` на 1. 5. Выведите значение переменной `count`.
Вот полный код на языке C, который решает данную задачу:
```c
#include
int main() { int n, i; int arr[100]; int max_value, count;
// Ввод размера массива printf("Введите размер массива: "); scanf("%d", &n);
// Ввод элементов массива printf("Введите элементы массива: "); for (i = 0; i < n; i++) { scanf("%d", &arr[i]); }
// Нахождение элементов с максимальным значением max_value = arr[0]; count = 1;
for (i = 1; i < n; i++) { if (arr[i] > max_value) { max_value = arr[i]; count = 1; } else if (arr[i] == max_value) { count++; } }
// Вывод результата printf("Количество элементов с максимальным значением: %d\n", count);
return 0; } ```
Объяснение кода
1. Переменная `n` используется для хранения размера массива. 2. Массив `arr` используется для хранения введенных пользователем элементов. 3. Переменные `max_value` и `count` используются для хранения максимального значения и количества элементов с максимальным значением соответственно. 4. С помощью цикла `for` пользователь вводит элементы массива. 5. Затем с помощью еще одного цикла `for` находится максимальное значение и количество элементов с этим значением. 6. Результат выводится на экран.Пример ввода и вывода:
``` Введите размер массива: 8 Введите элементы массива: 3 4 5 5 3 4 5 5 Количество элементов с максимальным значением: 4 ```
В этом примере массив имеет размер 8 и содержит элементы 3, 4, 5, 5, 3, 4, 5, 5. Максимальное значение в массиве - 5, и количество элементов с этим значением равно 4.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
