Вопрос задан 18.02.2019 в 13:28. Предмет Информатика. Спрашивает Романенкова Маша.

Большая просьба напишите программу паскаль (сравнить 4чисел)

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Лукьянцева Таня.
Var
a, b, c, d:integer;
p: integer;
begin
writeln('Введите первое число:');
readln(a);
writeln('Введите второе число:');
readln(b);
writeln('Введите третье число:');
readln(c);
writeln('Введите четвёртое число:');
readln(d);
if a>b then
writeln('1 число больше 2');
if a<b then
writeln('1 меньше 2');
if b>c then
writeln('2 число больше 3');
if b<c then
writeln('2 меньше 3');
if c>d then
writeln('3 число больше 4');
if c<d then
writeln('3 меньше 4');
if c>d then
writeln('4 число больше 1');
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на языке Pascal, которая сравнивает четыре числа:

```pascal program CompareNumbers;

var num1, num2, num3, num4: integer;

begin writeln('Введите четыре числа:'); readln(num1, num2, num3, num4);

if (num1 > num2) and (num1 > num3) and (num1 > num4) then writeln('Первое число является наибольшим.') else if (num2 > num1) and (num2 > num3) and (num2 > num4) then writeln('Второе число является наибольшим.') else if (num3 > num1) and (num3 > num2) and (num3 > num4) then writeln('Третье число является наибольшим.') else if (num4 > num1) and (num4 > num2) and (num4 > num3) then writeln('Четвертое число является наибольшим.') else writeln('Числа равны или имеют одинаковые значения.');

readln; end. ```

В этой программе мы объявляем четыре переменные `num1`, `num2`, `num3` и `num4`, которые будут использоваться для хранения введенных чисел. Затем мы запрашиваем у пользователя ввод четырех чисел с помощью `readln`.

Далее, с помощью условных операторов `if` и `else if`, мы сравниваем значения этих чисел и выводим сообщение о том, какое число является наибольшим. Если все числа равны или имеют одинаковые значения, выводится сообщение об этом.

Надеюсь, это поможет вам! Если у вас есть еще вопросы, не стесняйтесь задавать.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос