Написать программу на паскале: вычислить средний балл ученика по 12 предметам.Оценки по каждому
предмету задать самостоятельно.Ответы на вопрос
type ocenka=1..5;
var a: array [1..12] of ocenka;
i:integer;
s: real;
begin
s:=0;
for i:=1 to 12 do begin
readln(a[i]);
s:=s+a[i];
end;
writeln(s/12:0:3);
end.
Программа на Паскале для вычисления среднего балла ученика по 12 предметам может выглядеть следующим образом:
```pascal program AverageGradeCalculator;
var grades: array[1..12] of integer; i: integer; sum: integer; average: real;
begin sum := 0;
// Ввод оценок по каждому предмету for i := 1 to 12 do begin write('Введите оценку по предмету ', i, ': '); readln(grades[i]); sum := sum + grades[i]; end;
// Вычисление среднего балла average := sum / 12;
// Вывод результата writeln('Средний балл ученика: ', average:0:2); end. ```
Эта программа создает массив из 12 элементов, в котором хранятся оценки по каждому предмету. Затем она запрашивает у пользователя ввод оценок и суммирует их. После этого программа вычисляет средний балл, делая сумму оценок по предметам и делит ее на количество предметов. В конце программа выводит средний балл ученика.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
