1. Дано целое число c. Напишите программу, которая возводит в квадрат частное от целочисленного
деления числа c на 5 и выводит на экран монитора результат. 2. Дано целое число c. Напишите программу, которая возводит в квадрат остаток от целочисленного деления числа c на 10 и выводит на экран монитора результат.Ответы на вопрос
#include <iostream>
using namespace std;
int main() {
int c;
cin >> c;
cout << (c/5)*(c/5) << endl;
}
2)
#include <iostream>
using namespace std;
int main() {
int c;
cin >> c;
cout << (c%10)*(c%10) << endl;
}
1. Программа для возвода в квадрат частного от целочисленного деления числа c на 5
Для написания программы, которая возводит в квадрат частное от целочисленного деления числа c на 5 и выводит результат на экран монитора, можно использовать язык программирования Python. Вот пример программы:
```python c = int(input("Введите целое число c: ")) # Вводим целое число c с помощью функции input() и преобразуем его в целочисленный тип с помощью функции int()
quotient = c // 5 # Вычисляем частное от деления числа c на 5 с помощью оператора //
result = quotient 2 # Возводим частное в квадрат с помощью оператора
print("Результат:", result) # Выводим результат на экран монитора ```
Программа запрашивает у пользователя ввод целого числа c, затем вычисляет частное от деления числа c на 5 с помощью оператора // и возводит это частное в квадрат с помощью оператора **. Затем программа выводит результат на экран монитора.
2. Программа для возвода в квадрат остатка от целочисленного деления числа c на 10
Для написания программы, которая возводит в квадрат остаток от целочисленного деления числа c на 10 и выводит результат на экран монитора, также можно использовать язык программирования Python. Вот пример программы:
```python c = int(input("Введите целое число c: ")) # Вводим целое число c с помощью функции input() и преобразуем его в целочисленный тип с помощью функции int()
remainder = c % 10 # Вычисляем остаток от деления числа c на 10 с помощью оператора %
result = remainder 2 # Возводим остаток в квадрат с помощью оператора
print("Результат:", result) # Выводим результат на экран монитора ```
Программа запрашивает у пользователя ввод целого числа c, затем вычисляет остаток от деления числа c на 10 с помощью оператора % и возводит этот остаток в квадрат с помощью оператора **. Затем программа выводит результат на экран монитора.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
