Вопрос задан 17.02.2019 в 13:27. Предмет Информатика. Спрашивает Давидюк Виктория.

Pascal, используя Case. Хотя бы одну 1)Составить программу, которая анализирует студента по его

оценкам и выводит на экран одно из сообщений: “Вы учитесь плохо”, “Вы учитесь посредственно” и т.д. 2)Дано целое число k(1<=k<=365). Определить, каким будет K-й день года: субботой, воскресеньем или рабочим днем, если 1 января – понедельник. 3)Ввести возраст ребенка. Вывести в какой отряд пионерского лагеря он попадет, если известен принцип распределения: с 6 до 7 лет - 5 отряд; с 7 до 9 лет - 4 отряд; с 9 до 11 лет - 3 отряд; с 11 до 13 - 2 отряд с 13 до 15 (включительно) - 1 отряд.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Калмагамбетова Арай.
Program student;

var

ocenka:byte;

begin

writeln('vvedite ocenku');

readln(ocenka);

case ocenka of

1:  writeln('ochen ploho!');

2:  writeln('ploho');

3:  writeln('udovletvoritelno');

4:  writeln('horosho');

5:  writeln('otlichno');

end;

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения задачи на языке программирования Pascal с использованием оператора Case, давайте рассмотрим каждую из задач по очереди.

1) Программа, анализирующая студента по его оценкам

Для этой задачи мы можем написать программу, которая будет анализировать оценки студента и выводить соответствующее сообщение. Вот пример программы на Pascal, использующей оператор Case для этой задачи:

```pascal program StudentGradesAnalysis; var grade: integer; begin write('Enter the student''s grade: '); readln(grade);

case grade of 1, 2: writeln('You are studying poorly'); 3, 4: writeln('You are studying mediocre'); 5: writeln('You are studying well'); else writeln('Invalid grade entered'); end;

readln; end. ```

2) Определение дня недели по номеру дня в году

Для второй задачи, определяющей день недели по номеру дня в году, мы также можем воспользоваться оператором Case. Вот пример программы на Pascal:

```pascal program DayOfWeek; var k, dayOfWeek: integer; begin write('Enter the day number (1-365): '); readln(k);

dayOfWeek := (k + 0) mod 7; // 1 января - понедельник, поэтому добавляем 0

case dayOfWeek of 1, 2, 3, 4, 5: writeln('It''s a weekday'); 6: writeln('It''s Saturday'); 0: writeln('It''s Sunday'); end;

readln; end. ```

3) Распределение ребенка по отрядам пионерского лагеря

Для данной задачи также напишем программу с использованием оператора Case:

```pascal program PioneerCamp; var age, camp: integer; begin write('Enter the child''s age: '); readln(age);

case age of 6..7: camp := 5; 8..9: camp := 4; 10..11: camp := 3; 12..13: camp := 2; 14..15: camp := 1; else camp := 0; // Недопустимый возраст end;

if camp <> 0 then writeln('The child will be in camp ', camp) else writeln('Invalid age entered');

readln; end. ```

Вот примеры программ на Pascal для каждой из задач. Надеюсь, это поможет вам разобраться в использовании оператора Case для решения данных задач.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос