Написать программу на С++. Написать подпрограмму, которая принимает один аргумент и выводит на
экран факториал переданного ей числа.Ответы на вопрос
using namespace std;
void fac(int n) {
int s=1;
for (int i=1; i<=n; i++) s*=i;
cout<<s<<endl;
}
int main() {
int n;
cout<<"number: "; cin>>n;
fac(n);
system("pause");
return 0;
}
Writing a C++ Program to Calculate Factorial
To write a C++ program that calculates the factorial of a given number, you can follow the steps below.
1. Include Necessary Libraries: - Include the necessary libraries for input/output operations and mathematical calculations.
```cpp
#include
2. Define the Main Function: - Define the main function where the program execution begins.
```cpp int main() { // Program logic will go here return 0; } ```
3. Accept User Input: - Accept the input from the user, which is the number for which the factorial needs to be calculated.
```cpp int num; cout << "Enter a number: "; cin >> num; ```
4. Calculate the Factorial: - Write a loop to calculate the factorial of the input number.
```cpp int factorial = 1; for (int i = 1; i <= num; i++) { factorial *= i; } ```
5. Display the Result: - Output the factorial of the input number.
```cpp cout << "Factorial of " << num << " = " << factorial << endl; ```
Putting it all together, the complete C++ program to calculate the factorial of a given number looks like this:
```cpp
#include
int main() { int num; cout << "Enter a number: "; cin >> num;
int factorial = 1; for (int i = 1; i <= num; i++) { factorial *= i; }
cout << "Factorial of " << num << " = " << factorial << endl;
return 0; } ```
This program prompts the user to enter a number, calculates its factorial, and then displays the result.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
