
Написать программу в Pascal. Массив из 11 элементов: -10, 37, 45, 50, 60, 67, 3, 12, 64, 2,
43.Вывести эти числа на экран в строку.

Ответы на вопрос

var i:integer;
begin
for i:=1 to 11 do write (a[I],' ');
readln;
end.



Программа на Pascal для вывода массива чисел на экран
```pascal program PrintArray;
var arr: array[1..11] of Integer; // объявляем массив из 11 элементов i: Integer; // переменная для цикла
begin // инициализируем массив arr[1] := -10; arr[2] := 37; arr[3] := 45; arr[4] := 50; arr[5] := 60; arr[6] := 67; arr[7] := 3; arr[8] := 12; arr[9] := 64; arr[10] := 2; arr[11] := 43;
// выводим элементы массива на экран в строку for i := 1 to 11 do begin write(arr[i], ' '); end;
readln; // ожидаем ввода пользователя перед закрытием программы end. ```
Объяснение программы: - Программа объявляет массив `arr` из 11 элементов типа `Integer`. - Затем каждому элементу массива присваиваются соответствующие значения. - Далее, с помощью цикла `for`, каждый элемент массива выводится на экран с помощью процедуры `write`. - В конце программы используется `readln` для ожидания ввода пользователя перед закрытием программы.
Результат выполнения программы: ``` -10 37 45 50 60 67 3 12 64 2 43 ```
Эта программа на Pascal выводит массив чисел на экран в строку.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili