Вопрос задан 15.02.2019 в 20:53. Предмет Информатика. Спрашивает Кварцхава Константин.

Помогите СРОЧНО пожалуйста!!!Напишите программы на языке Паскаль Задача1.Составить программу для

расчета z=2.5sin x^2+x^3 Число х вводится с клавиатуры. Задача 2.Задать 3 натуральных числа . Являются ли их сумма четным числом Задача 3.Напечатать все делители натурального числа N. ЗАРАНЕЕ СПАСИБО
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Вахрушева Алина.
//1
begin
var x:=readreal('Введите x: ');
write ('z=', 2.5*sin(sqr(x))+x*x*x);
end.

//2
begin
write (((readinteger('Введите 3 нат. числа: ')+readinteger+readinteger) mod 2)=0);
end.

//3
begin
var n:=readinteger ('Введите n: ');
for var i:=1 to  n do
if (n mod i)=0 then print (i);
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Задача 1: ```pascal program Task1; var x, z: real; begin writeln('Введите число x:'); readln(x); z := 2.5 * sin(x*x + x*x*x); writeln('Результат: z = ', z); end. ``` Задача 2: ```pascal program Task2; var num1, num2, num3: integer; sum: integer; begin writeln('Введите первое число:'); readln(num1); writeln('Введите второе число:'); readln(num2); writeln('Введите третье число:'); readln(num3); sum := num1 + num2 + num3; if sum mod 2 = 0 then writeln('Сумма чисел является четным числом') else writeln('Сумма чисел не является четным числом'); end. ``` Задача 3: ```pascal program Task3; var N, i: integer; begin writeln('Введите натуральное число N:'); readln(N); writeln('Делители числа ', N, ':'); for i := 1 to N do begin if N mod i = 0 then writeln(i); end; end. ```

Примечание: Все программы написаны на языке Паскаль. Вы можете скопировать каждую программу в среду разработки Паскаль и запустить ее для проверки.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос