Вопрос задан 13.02.2019 в 00:57.
Предмет Информатика.
Спрашивает Солнцев Иван.
Написать программу, выделяющую из некоторого заданного множества подмножество четных чисел.
Паскаль, как можно быстрее, пожалуйста.Ответы на вопрос
Отвечает Кнутов Мартин.
Var a,b:set of integer;
i,n: integer;
begin
write('кол-во элементов множества: ');
readln(n);
randomize;
for i:=1 to n do
a:=a+[random(250)];
write('элементы множества: ');
foreach i in a do
begin
write(i,' ');
if i mod 2 = 0 then b:=b+[i];
end;
writeln;
write('подмножество четных элементов: ');
foreach i in b do write(i,' ');
end.
i,n: integer;
begin
write('кол-во элементов множества: ');
readln(n);
randomize;
for i:=1 to n do
a:=a+[random(250)];
write('элементы множества: ');
foreach i in a do
begin
write(i,' ');
if i mod 2 = 0 then b:=b+[i];
end;
writeln;
write('подмножество четных элементов: ');
foreach i in b do write(i,' ');
end.
Топ вопросов за вчера в категории Информатика
Информатика 33
Информатика 27
Информатика 19
Информатика 34
Информатика 160
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
