Вопрос задан 12.02.2019 в 13:43. Предмет Информатика. Спрашивает Нестеров Николай.

Программирование на языке си! Любую из этих программ:1. Составить программу, которая определяет

произведение цифр четырехзначного числа, введенного пользователем. 2Составить программу, которая запрашивает у пользователя целочисленные корни многочлена четвертой степени и, используя теорему Виета, находит его коэффициенты. Вывести результат в форме таблицы, где первая строка – степени, а вторая – коэффициента при этих степенях.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Алтунин Кирилл.
1. #include <stdio.h>#include <ctype.h>
int main(int argc, char** argv){    char a, b, c, d;    if (scanf("%c%c%c%c", &a, &b, &c, &d) != 4)        printf("Input error\n");    else    {        if (isdigit(a) && isdigit(b) && isdigit(c) && isdigit(d) && (a > '0'))            printf("Sum is %d\n", a + b + c + d - 4 * '0');        else            printf("Is itn't correct number\n");    }    return 0;}
0 0
Отвечает Хусаинов Рузаль.
1. Программа (без проверки правильности ввода):
#include <stdio.h> 

int main() 
{ 
   int N;
   scanf ("%d", &N); 
   int sum; 
   sum = N/1000 + N/100%10 + N%100/10 + N%10;
   printf ("sum = %d",sum);
}

Пример:
5029
sum = 16
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос