Вопрос задан 28.04.2018 в 04:34.
Предмет Информатика.
Спрашивает Колочко Всеволод.
Дан массив из тридцати элементов. Проверьте, есть ли среди элементов стоящих на четных местах
такой, значение которого лежит в интервале от a до b. Если такой элемент существует - напишите YES, иначе напишите NO. Формат входных данных На первой строке через пробел записаны целые числа Arri (|Arri|≤1000) — элементы массива. На второй строке записано целые положительные числа a и b. Формат выходных данных Строка, содержащая запись YES либо NOОтветы на вопрос
Отвечает Кострик Алинка.
Var
i, x, y: integer;
a: array[1..30]of integer;
begin
readln(x, y);
for i := 1 to 30 do read(a[i]);
for i := 1 to 30 do if (i mod 2 = 0) and (a[i] >= x) and (a[i] <= y) then
begin
write('YES');
exit;
end;
write('NO');
end.
Топ вопросов за вчера в категории Информатика
Информатика 2212
Информатика 15
Информатика 635
Информатика 18
Информатика 61
Информатика 56
Информатика 42
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
