Вопрос задан 12.02.2019 в 02:48.
Предмет Информатика.
Спрашивает Захарова Алиса.
В паскале составить программу которая формирует массив из 16 случайных целых чисел в промежутке от
-12 до 10 и подсчитывает кол-во отрицательных и нулевых элементов. Распишите подробно, пожалуйста.Ответы на вопрос
Отвечает Губарев Олег.
При копировании кода на сайт из IDE автоматически убираются пробелы. Ниже будет скриншот того, как должен будет выглядеть код.
program zn; begin var a: array [1..16] of integer; var i, c: integer; c:=0; for i:=1 to 16 do begin a[i]:=random(20)-12; writeln(a[i],' '); if a[i]=0 then c:=c+1; if a[i]<0 then c:=c+1; end; writeln('Кол-во элементов раных 0 или меньше 0: ', c); end.
program zn; begin var a: array [1..16] of integer; var i, c: integer; c:=0; for i:=1 to 16 do begin a[i]:=random(20)-12; writeln(a[i],' '); if a[i]=0 then c:=c+1; if a[i]<0 then c:=c+1; end; writeln('Кол-во элементов раных 0 или меньше 0: ', c); end.
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 37
Информатика 11
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 30
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
