Вопрос задан 11.02.2019 в 09:24.
Предмет Информатика.
Спрашивает Кудинов Александр.
Составить программу вычисления функции y=1- при изменении аргумента x в интервале с шагом h=0.1
Ответы на вопрос
Отвечает Куркова Юлия.
Число повторений цикла = целая часть [(3-0.1)/0.1]+1 = 30
// PascalABC.NET 3.2, сборка 1383 от 09.02.2017
begin
for var i:=1 to 30 do begin
var x:=0.1*(i-1)+0.1; var y:=1-sin(x)/(1-ln(x+0.1));
Writeln(x:3:1,y:15:5)
end
end.
Результат
0.1 0.96174
0.2 0.90986
0.3 0.84579
0.4 0.77000
0.5 0.68267
0.6 0.58380
0.7 0.47331
0.8 0.35102
0.9 0.21667
1.0 0.06988
1.1 -0.08992
1.2 -0.26355
1.3 -0.45217
1.4 -0.65751
1.5 -0.88208
1.6 -1.12960
1.7 -1.40571
1.8 -1.71913
1.9 -2.08389
2.0 -2.52355
2.1 -3.08055
2.2 -3.83866
2.3 -4.98810
2.4 -7.06916
2.5 -12.45227
2.6 -75.39064
2.7 15.42904
2.8 6.17670
2.9 3.42616
3.0 2.07396
// PascalABC.NET 3.2, сборка 1383 от 09.02.2017
begin
for var i:=1 to 30 do begin
var x:=0.1*(i-1)+0.1; var y:=1-sin(x)/(1-ln(x+0.1));
Writeln(x:3:1,y:15:5)
end
end.
Результат
0.1 0.96174
0.2 0.90986
0.3 0.84579
0.4 0.77000
0.5 0.68267
0.6 0.58380
0.7 0.47331
0.8 0.35102
0.9 0.21667
1.0 0.06988
1.1 -0.08992
1.2 -0.26355
1.3 -0.45217
1.4 -0.65751
1.5 -0.88208
1.6 -1.12960
1.7 -1.40571
1.8 -1.71913
1.9 -2.08389
2.0 -2.52355
2.1 -3.08055
2.2 -3.83866
2.3 -4.98810
2.4 -7.06916
2.5 -12.45227
2.6 -75.39064
2.7 15.42904
2.8 6.17670
2.9 3.42616
3.0 2.07396
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
