Вопрос задан 10.02.2019 в 21:54.
Предмет Информатика.
Спрашивает Лозейко Саша.
Составить программу на языке Паскаля: Даны числа a,b,c. Составить программу, выводящую на экран
сообщение, в зависимости от того какой треугольник можно построить с такими длина сторон: равносторонний,равнобедренный или какой либо другой.Ответы на вопрос
Отвечает Горин Алексей.
var a,b,c: integer;
begin
readln(a,b,c);
if (a>b+c) or (b>a+c) or (c>a+b) then begin writeln('Треугольник не сущесвует'); exit; end;
if (a=b) or (b=c) or (a=c) then writeln('Равнобедренный треугольник');
if (a=b) and (b=c) and (a=c) then writeln('Равносторонний треугольник');
if (sqr(c)=sqr(a)+sqr(b)) or (sqr(b)=sqr(c)+sqr(a)) or (sqr(a)=sqr(b)+sqr(c)) then writeln('Прямоугольный треугольник');
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
