Вопрос задан 06.02.2019 в 19:23.
Предмет Информатика.
Спрашивает Бабич Сабина.
Составить программу нахождения произведения четных двузначных чисел, со всеми видами цикла.
Ответы на вопрос
Отвечает Долганов Ясон.
1)
#include <iostream>
using namespace std;
int main()
{
unsigned long long p = 1;
for (int i = 10; i<=98; i+=2)
p*=i;
cout <<"Proizvedenie: " <<p <<endl;
return 0;
}
2)
#include <iostream>
using namespace std;
int main()
{
unsigned long long p = 1;
int i = 10;
while (i<=98)
{
p*=i;
i+=2;
}
cout <<"Proizvedenie: " <<p <<endl;
return 0;
}
3)
#include <iostream>
using namespace std;
int main()
{
unsigned long long p = 1;
int i = 10;
do
{
p*=i;
i+=2;
}
while (i<=98);
cout <<"Proizvedenie: " <<p <<endl;
return 0;
}
Столь большое произведение не поместиться даже
unsigned long long,поэтому результатом будет выдавать 0
#include <iostream>
using namespace std;
int main()
{
unsigned long long p = 1;
for (int i = 10; i<=98; i+=2)
p*=i;
cout <<"Proizvedenie: " <<p <<endl;
return 0;
}
2)
#include <iostream>
using namespace std;
int main()
{
unsigned long long p = 1;
int i = 10;
while (i<=98)
{
p*=i;
i+=2;
}
cout <<"Proizvedenie: " <<p <<endl;
return 0;
}
3)
#include <iostream>
using namespace std;
int main()
{
unsigned long long p = 1;
int i = 10;
do
{
p*=i;
i+=2;
}
while (i<=98);
cout <<"Proizvedenie: " <<p <<endl;
return 0;
}
Столь большое произведение не поместиться даже
unsigned long long,поэтому результатом будет выдавать 0
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 36
Информатика 11
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 30
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
