Вопрос задан 04.02.2019 в 16:08.
Предмет Информатика.
Спрашивает Ивакин Влад.
Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию. Напишите программу,
которая вычисляет НОК двух чисел. Используйте функцию.Ответы на вопрос
Отвечает Лапчук Настюша.
Программа с НОД
var t,t1,x,y,z:integer;
Function NOD(a, b: integer): integer;
Begin If a=b then NOD:=a
else if a>b then NOD:=NOD(a-b, b)
Else NOD:=NOD(a, b-a);
End;
begin
writeln('Введите 2 числа');
readln(x,y);
t:=NOD(X,Y);
writeln(t);
end.
var t,t1,x,y,z:integer;
Function NOD(a, b: integer): integer;
Begin If a=b then NOD:=a
else if a>b then NOD:=NOD(a-b, b)
Else NOD:=NOD(a, b-a);
End;
begin
writeln('Введите 2 числа');
readln(x,y);
t:=NOD(X,Y);
writeln(t);
end.
Топ вопросов за вчера в категории Информатика
Информатика 33
Информатика 32
Информатика 51
Информатика 95
Информатика 36
Информатика 23
Информатика 36
Информатика 12
Информатика 14
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
