Вопрос задан 02.02.2019 в 17:28. Предмет Информатика. Спрашивает Конторщикова Вера.

Составьте программу ,которая позволяет удалить символы t из строки s.Строка s и символ t,который

надо удалить,вводятся с клавиатуры
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Манапова Луиза.
Тогда вот, все по букве задания

var
  s : string;
  t : char;
  i : integer;
begin
  readln (s);
  read (t);
  i := 1;
  while (i <= length (s)) do
  begin
    if s[i] = t then delete (s, i, 1)
    else i := i + 1;
  end;
  writeln (s);
end.
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос