Вопрос задан 30.01.2019 в 09:16. Предмет Информатика. Спрашивает Иванова Ангелина.

Pascal abcнапишите программу, которая сортирует список работников компании по фамилии в алфавитном

порядке. В списке не более 10000 строк, ввод заканчивается пустой строкой. Входные данные В каждой входной строке записаны данные о сотруднике в формате <инициалы> <фамилия>. Фамилия отделяется от инициалов пробелом. Ввод заканчивается пустой строкой. Выходные данные Программа должна вывести список сотрудников в алфавитном порядке, добавив нумерацию. Примеры входные данные J.X. Smith B.A. Weiter A.C. Johnes выходные данные 1. A.C. Johnes 2. J.X. Smith 3. B.A. Weiter
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Бабина Мария.
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

type
  fs=(string,string);

begin
  var L:=new List<fs>;
  repeat
    var aw:=ReadlnString('>').ToWords;
    if aw.Length=0 then break;
    L.Add((aw[1],aw[0]))
  until false;
  var a:=L.OrderBy(t->t[0]);
  var i:=1;
  foreach var x in a do begin
    Writeln(i:4,' ',x[1],' ',x[0]);
    i+=1
    end
end.

Пример
> J.X. Smith
> B.A. Weiter
> A.C. Johnes
>
   1 A.C. Johnes
   2 J.X. Smith
   3 B.A. Weiter
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос