Вопрос задан 27.01.2019 в 02:18.
Предмет Информатика.
Спрашивает Истомина Ксения.
Надо написать программу Вычислите N! ("эн-факториал") – произведение всех натуральных чисел от 1 до
N ( N!=1∙2∙3∙…∙ N ). Входные данные Вводится единственное число N – натуральное, не превосходит 12. Выходные данные Выведите полученное значение N! Примеры входные данные 2 выходные данные 2 входные данные 3 выходные данные 6 (На Паскале) Буду благодаренОтветы на вопрос
Отвечает Назарова Кристина.
Var b,i,k,n: int64;
begin
readln(n);
b:=1;
for i := 1 to n do
b:=b*i;
writeln(b);
end.
Входные данные подставлять в переменную n
begin
readln(n);
b:=1;
for i := 1 to n do
b:=b*i;
writeln(b);
end.
Входные данные подставлять в переменную n
Отвечает Логинов Даниил.
Program fact;
var
n, f, i: integer;
begin
f := 1;
readln(n);
for i := 2 to n do
f := f * i;
writeln(f);
end.
var
n, f, i: integer;
begin
f := 1;
readln(n);
for i := 2 to n do
f := f * i;
writeln(f);
end.
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 24
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
