Вопрос задан 26.01.2019 в 12:37. Предмет Информатика. Спрашивает Кот Ренат.

Нужно написать программу на вход в pascal Программа получает 3 действительных числа- значение

градусных мер углов треугольника 1 программа должна проверить что это треугольник ( сложить 3 угла и получить 180) 2 программа должна вывести какой это треугольник( равнобедренный 2 угла равны, равносторонний все 3 угла равны 60, или прямоугольный угол 90) 3 если это прямоугольный треугольник то программа должна запросить 2 стороны треугольника ( 2 катета) и найти его площадь. ( площадь равна половине произведения катетов) ПОМОГИТЕ НАПИСАТЬ ПРОГРАММУ В PASCAL ДАЮ 99 БАЛЛОВ!!
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Маслов Витя.
Uses crt;
var a,b,c: Integer;
Begin
Write('Введите три угла: ');
Readln(a, b, c);
If (a+b+c)=180 then
Writeln('Это треугольник')
Else Writeln('Это не треугольник');
End.

Вторая:
uses crt;
var a,b,c: Integer;
Begin
Write('Введите три угла: ');
Read(a,b,c);
If (a=b) or (a=c) or (b=c) then
Writeln('Треугольник равнобедренный');
End.

Третья:
uses crt;
var a,b,c: Integer;
d,e,f: Real;
Begin
Write('Введите три угла: ');
Readln(a,b,c);
If (a=90) or (b=90) or (c=90) then
Write('Введите два катета: ');
Readln(d,e);
f:=(d+e)/2;
Writeln('Площадь треугольника: ', f, '.');
End.

Если надо объединить в одну - пиши.
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос