
Вопрос задан 25.01.2019 в 21:47.
Предмет Информатика.
Спрашивает Павлова Анна.
Составьте программу вычисления диагоналей параллелограмма по сторонам и углу


Ответы на вопрос

Отвечает Степкин Артем.
// PascalABC.NET 3.3, сборка 1541 от 29.09.2017
// Внимание! Если программа не работает, обновите версию!
begin
var (a,b,ag):=ReadReal3('Введите размеры сторон и угол между ними:');
var d1:=Sqrt(a*a+b*b-2*a*b*Cos(DegToRad(ag)));
var d2:=Sqrt(a*a+b*b-2*a*b*Cos(DegToRad(180-ag)));
Writeln('d1=',d1,', d2=',d2);
end.
Пример
Введите размеры сторон и угол между ними: 5 2 60
d1=4.35889894354067, d2=6.2449979983984
// Внимание! Если программа не работает, обновите версию!
begin
var (a,b,ag):=ReadReal3('Введите размеры сторон и угол между ними:');
var d1:=Sqrt(a*a+b*b-2*a*b*Cos(DegToRad(ag)));
var d2:=Sqrt(a*a+b*b-2*a*b*Cos(DegToRad(180-ag)));
Writeln('d1=',d1,', d2=',d2);
end.
Пример
Введите размеры сторон и угол между ними: 5 2 60
d1=4.35889894354067, d2=6.2449979983984


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili