Вопрос задан 23.04.2018 в 21:59.
Предмет Информатика.
Спрашивает Балабушевич Евгений.
Напишите пожалуйста программу с помощью Паскаля:Дана последовательность 5 9 13 17 21 25 29 33 37 41
45 49. Составьте программу для подсчета числа слагаемых сумма которых равна 324Ответы на вопрос
Отвечает Иванова Полина.
var sum, i, s: integer; //обыявляем необходимые переменные
//sum - сумма, i - кол-во слогаемых, s - само слогаемое
begin //начало
sum := 0; i := 1; s := 5; //первое слогаемое = 5
while (sum < 324) do //пока сумма меньше 324
begin
sum := sum + s; //к сумме прибавляем слагаемое
s := s + 4; //увеличиваем слогаемое
i := i + 1; //увеличиваем кол-во слогаемых
end;
writeln ('Слогаемых: '); // выводим кол-во слогаемых
write (i);
end. //конец
Топ вопросов за вчера в категории Информатика
Информатика 11
Информатика 1255
Информатика 115
Информатика 1220
Информатика 11
Информатика 10
Информатика 66
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
