Вопрос задан 20.01.2019 в 08:01.
Предмет Информатика.
Спрашивает Физлова Айше.
1)составьте программу вычисления суммы чисел в диапазоне от 45 до 115 45+....+115 оператор
While2)Составьте программу которая выводит на экран числа кратные 2 и 13 в диапазоне от 2 до 1503)Дано вещественное число А и целое число N(>0).Испульзуя один цикл вывести все целые степени числа А от 1 до N------------------------ОПЕРАТОР WHILEОтветы на вопрос
Отвечает Шивырталов Саша.
1)var i,sum:integer;
begin
sum:=0;
i:=45;
while (i<=115) do begin
sum:=sum+i;
i:=i+1;
end;
writeln( 'Сумма = ', sum );
end.
2)var i:integer;
begin
i:=2;
while (i<=150) do begin
If (i mod 2=0) and (i mod 13=0) then
writeln(i);
i:=i+1;
end;end.
3)var c,A,i,N:integer;
begin
write('Введите целое число (N>0) N = ');read(N);
write('Введите целое число A = ');read(A);
c:=1;
i:=1;
while (i<=N) do begin
c:=c*A;
i:=i+1;
Writeln('A в степени ',i,' := ',c);
end;end.
begin
sum:=0;
i:=45;
while (i<=115) do begin
sum:=sum+i;
i:=i+1;
end;
writeln( 'Сумма = ', sum );
end.
2)var i:integer;
begin
i:=2;
while (i<=150) do begin
If (i mod 2=0) and (i mod 13=0) then
writeln(i);
i:=i+1;
end;end.
3)var c,A,i,N:integer;
begin
write('Введите целое число (N>0) N = ');read(N);
write('Введите целое число A = ');read(A);
c:=1;
i:=1;
while (i<=N) do begin
c:=c*A;
i:=i+1;
Writeln('A в степени ',i,' := ',c);
end;end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
