Вопрос задан 19.01.2019 в 16:31. Предмет Информатика. Спрашивает Копосович Ярослав.

Требовалось написать программу, при выполнении которой с клавиатуры считывается натуральное число

N, не превосходящее 10^9, и выводится произведение цифр этого числа. Программист торопился и написал программу неправильно. (Ниже для Вашего удобства программа представлена на четырёх языках программирования. )var N, product: longint; digit: integer;begin readln(N); product:=N mod 10; while N >= 10 do begin digit:= N mod 10; product:= product*digit; N:= N div 10; end; writeln(product);end. Последовательно выполните следующее. 1. Напишите, что выведет эта программа при вводе числа 532.2. Найдите все ошибки в этой программе (их может быть одна или несколько) . Для каждой ошибки:1)выпишите строку, в которой сделана ошибка;2)укажите, как исправить ошибку, - приведите правильный вариант строки.Обратите внимание, что требуется найти ошибки в имеющейся программе, а не написать свою, возможно, использующую другой алгоритм решения. Исправление ошибки должно затрагивать только строку, в которой находится ошибка.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Фролик Сеня.
1) для числа 532 от напечатает 60
2) ошибка: product:=N mod 10;
нужно написать:
product:=1;

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос