Вопрос задан 18.01.2019 в 12:46.
Предмет Информатика.
Спрашивает Федотушкина Дарья.
Написать программу обработки двумерного массива: дан массив А 15 строк и 15 столбцов. Заполнить
массив случайными числами, найти мах, мин, и сумму элементов всего массиваНужно в тетраде написатьНужно написать так,как в паскалеОтветы на вопрос
Отвечает Рейникова Ксюша.
var a, b, c, d, i, j :integer;
s :array [1..100,1..100] of integer;
begin
b:=63999;
c:=-63999;
for i:=1 to 15 do
begin
writeln;
for j:=1 to 15 do
begin
s[i,j]:=random(127998)-63999;
a:=a+s[i,j];
if s[i,j]>c then c:=s[i,j];
if s[i,j]<b then b:=s[i,j];
write (s[i,j],' ');
end;
end;
writeln;
writeln ('Сумма элементов = ', a);
writeln ('Максимальный элемент = ', c);
writeln ('Минимальный элемент = ', b);
end.
s :array [1..100,1..100] of integer;
begin
b:=63999;
c:=-63999;
for i:=1 to 15 do
begin
writeln;
for j:=1 to 15 do
begin
s[i,j]:=random(127998)-63999;
a:=a+s[i,j];
if s[i,j]>c then c:=s[i,j];
if s[i,j]<b then b:=s[i,j];
write (s[i,j],' ');
end;
end;
writeln;
writeln ('Сумма элементов = ', a);
writeln ('Максимальный элемент = ', c);
writeln ('Минимальный элемент = ', b);
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
