Вопрос задан 16.01.2019 в 13:00. Предмет Информатика. Спрашивает Миронович Олег.

ОЧЕНЬ СРОЧНО НУЖНО написать программу на С++. Идет n-я секунда суток. Определить, сколько полных

часов и полных минут прошло до этого момента. + Отформатировать исходный код программы. + Определить ограничения на задаваемые пользователем значения и не допустить ввода неверных щначений
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Левченкова Ксения.

#include<iostream.h>


 using namespace std;


int main() 

{

    int n=0;

    cout<<"Введите секунды."<<endl;

    cin>>n;

    if(n>60*60*24)

    {

     cout<<"Неправельный ввод: в сутках меньше, чем "<<n<<" секунд"<<endl;

    }

    else

    {

     cout<<"Прошло полных часов: "<<(n-n%3600)/3600<<endl;

     cout<<"Прошло полных минут: "<<(n-n%60)/60<<endl;

    }

    system("pause");
    return 0;   
}

 

/*

 В некоторых компиляторах нельзя выводить русский текст таким образом, нужно выводить английский текст или второй вариант программы:

 

#include<iostream.h>

#include<windows.h>


 using namespace std;

 

char bufRus[256];
 
char* Rus(const char* text)

{
      CharToOem(text, bufRus);
      return bufRus;
}


int main() 

{

    int n=0;

    cout<<Rus("Введите секунды.")<<endl;

    cin>>n;

    if(n>60*60*24)

    {

     cout<<Rus("Неправельный ввод: в сутках меньше, чем ")<<n<<Rus(" секунд")<<endl;

    }

    else

    {

     cout<<Rus("Прошло полных часов: ")<<(n-n%3600)/3600<<endl;

     cout<<Rus("Прошло полных минут: ")<<(n-n%60)/60<<endl;

    }

    system("pause");
    return 0;   
}

 

 P.S сорри, что не срочно, увидел только сейчас.

*/

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос