Вопрос задан 22.04.2018 в 19:37.
Предмет Информатика.
Спрашивает Добрынина Ксения.
Дан целочисленный массив из 31 элемента, элементы массива могут принимать значения от -20 до 20.
Написать программу, которая выводит среднюю температуру среди дней, когда была оттепель.Ответы на вопрос
Отвечает Миляев Руслан.
Var a,b,i:integer;
n:real;
mass:array[1..31] of integer;
begin
for i:=1 to 31 do begin
mass[i]:=random(40)-20;
if mass[i]>0 then begin
b:=b+1;
a:=a+mass[i];
end;
end;
writeln('Полученные значения');
for i:=1 to 31 do
write(mass[i]:4);
n:=a/b;
writeln;
writeln('Средняя температура равна ',n:3:1);
end.
Топ вопросов за вчера в категории Информатика
Информатика 23
Информатика 38
Информатика 20
Информатика 14
Информатика 19
Информатика 21
Информатика 28
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
