Вопрос задан 15.01.2019 в 22:13.
Предмет Информатика.
Спрашивает Просвирников Ярослав.
Составить программу вычисления среднего арифметического элементов с четными номерами. массив
состоит из n элементов заданных с клавиатурыОтветы на вопрос
Отвечает Бебякина Лиза.
Program qq;
const N=(количество чисел в массиве);
var A:array[1..N] of integer;
i, S,k,SA:integer;
begin
for i:=1 to N do readln(A[i]);
S=0; SA:=0; k:=0;
for i:=0 to N do
if (imod2=0) then begin
S=S+A[i];
k:=k+1;
end;
SA:=S/k;
writeln(sa);
end.
const N=(количество чисел в массиве);
var A:array[1..N] of integer;
i, S,k,SA:integer;
begin
for i:=1 to N do readln(A[i]);
S=0; SA:=0; k:=0;
for i:=0 to N do
if (imod2=0) then begin
S=S+A[i];
k:=k+1;
end;
SA:=S/k;
writeln(sa);
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
