
Вопрос задан 15.01.2019 в 13:29.
Предмет Информатика.
Спрашивает Урбанович Ваня.
Напишите программу на Паскале.Дан целочисленный квадратный массив 10x10.Найти сумму максимальных
элементов из каждой строки.Предпологается, что в каждой строке такой элемент единственный

Ответы на вопрос

Отвечает Порядина Оля.
var
a : array [1..10] of longint;
i,j,max,ans : longint;
begin
for i:=1 to 10 do
begin
max:=-maxlongint;
for j:=1 to 10 do
begin
read(a[i]);
if a[i]>max then max:=a[i];
end;
ans:=ans+max;
writeln;
end;
writeln(ans);
end.
И этот массив не квадратный. Такие массивы называют двумерными массивами.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili