
Вопрос задан 15.01.2019 в 04:01.
Предмет Информатика.
Спрашивает Мудрых Георгий.
Составьте программу в Паскале для проверки утверждения: "Результатами вычислений по формуле х²+х+41
при 0<х<40 являются простые числа". Все результаты вывести на экран.

Ответы на вопрос

Отвечает Неретина Алина.
Var A,x,d,k,p:integer;
Begin
WriteLn('f(x) = x^2 +x +41');
p:=0;
For x:= 1 to 39 do
Begin
A:=x*x+x+41;
Write('f(',x,') = ',A);
d:=2;
k:=0;
While (A<>0)and(d<A) do
Begin
if A mod d = 0 then k:=k+1;
d:=d+1
End;
if k = 0 then WriteLn(' - простое')
else
Begin
WriteLn(' - не является простым');
p:=1;
End
End;
if p = 0 then WriteLn('Все полученные числа - простые')
else WriteLn('Не все полученные числа являются простыми');
End.
Begin
WriteLn('f(x) = x^2 +x +41');
p:=0;
For x:= 1 to 39 do
Begin
A:=x*x+x+41;
Write('f(',x,') = ',A);
d:=2;
k:=0;
While (A<>0)and(d<A) do
Begin
if A mod d = 0 then k:=k+1;
d:=d+1
End;
if k = 0 then WriteLn(' - простое')
else
Begin
WriteLn(' - не является простым');
p:=1;
End
End;
if p = 0 then WriteLn('Все полученные числа - простые')
else WriteLn('Не все полученные числа являются простыми');
End.


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili