Вопрос задан 15.01.2019 в 00:46.
Предмет Информатика.
Спрашивает Мирный Слава.
Помогите написать программу на паскале Дан целочисленный массив из 20 элементов. Элементы массива
могут принимать целые значения от -10000 до 10000 включительно. Опишите на естественном языке или на одном из языков программирования алгоритм, позволяющий найти и вывести количество пар элементов массива, сумма которых четна и положительна. Под парой подразумевается два подряд идущих элемента массива.Ответы на вопрос
Отвечает Лукин Даниил.
Program gt;
var a:array[1..20]of longint;
i,h:longint;
begin
for i:=1 to 20 do
read(a[i]);
for i:=1 to 19 do
if((a[i]+a[i+1]>0)and((a[i]+a[i+1])mod 2=0))then h:=h+1;
writeln(h);
end.
var a:array[1..20]of longint;
i,h:longint;
begin
for i:=1 to 20 do
read(a[i]);
for i:=1 to 19 do
if((a[i]+a[i+1]>0)and((a[i]+a[i+1])mod 2=0))then h:=h+1;
writeln(h);
end.
Топ вопросов за вчера в категории Информатика
Информатика 17
Информатика 40
Информатика 27
Информатика 61
Информатика 10
Информатика 13
Информатика 42
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
