Вопрос задан 14.01.2019 в 11:18.
Предмет Информатика.
Спрашивает Грачев Алексей.
1) Написать программу, находящую для натурального числа все его натуральные делители. 2) Написать
программу, вычисляющую наибольший общий делитель двух натуральных чисел.Ответы на вопрос
Отвечает Сахаров Андрей.
Задача №1
//PascalABC.NET (версия 3.1, сборка 1196 от 09.03.2016)
Var n, i: integer;
Begin
writeln ('Введите число');
readln(n);
writeln('Делители числа:');
for i := 1 to n div 2 do
if (n mod i) = 0 then begin
write(i,' ');
end;
End.
Задача №2 (алгоритм не очень шустрый, но работает и понятный)
//PascalABC.NET (версия 3.1, сборка 1196 от 09.03.2016)
var
a, b, x, y, nod: integer;
begin
writeln('Введите a,b');
readln(a, b);
x := a;y := b;
while x <> y do
if x > y
then x := x - y
else y := y - x;
nod := x;
writeln('NOD(', a, ',', b, ')=', nod);
end.
//PascalABC.NET (версия 3.1, сборка 1196 от 09.03.2016)
Var n, i: integer;
Begin
writeln ('Введите число');
readln(n);
writeln('Делители числа:');
for i := 1 to n div 2 do
if (n mod i) = 0 then begin
write(i,' ');
end;
End.
Задача №2 (алгоритм не очень шустрый, но работает и понятный)
//PascalABC.NET (версия 3.1, сборка 1196 от 09.03.2016)
var
a, b, x, y, nod: integer;
begin
writeln('Введите a,b');
readln(a, b);
x := a;y := b;
while x <> y do
if x > y
then x := x - y
else y := y - x;
nod := x;
writeln('NOD(', a, ',', b, ')=', nod);
end.
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 36
Информатика 11
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 30
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
