Вопрос задан 14.01.2019 в 05:46.
Предмет Информатика.
Спрашивает Бондик Яна.
Написать программу в паскале 1.Вычислить сумму и произведение n первых членов арифметической
прогрессии: а1=2; d=3; an=an-1+d. 2,дано натуральное число n. Вычислить (1+1/12)(1+1/22) … (1+1/n2). 3.Дано целое число А. Найти произведение целых чисел из промежутка от 1 до АОтветы на вопрос
Отвечает Луценко Дарья.
1)
var a,s,p,n,i:integer;
begin
readln(n);
s:=0; p:=1; a:=2;
for i:=1 to n do begin
p:=p*a;
s:=s+a;
a:=a+3;
end;
writeln(s,' 'p);
end.
2)
3)var a,p,i:integer;
begin
readln(a);
p:=1;
for i:=1 to a do
p:=p*i;
writeln(p);
end.
var a,s,p,n,i:integer;
begin
readln(n);
s:=0; p:=1; a:=2;
for i:=1 to n do begin
p:=p*a;
s:=s+a;
a:=a+3;
end;
writeln(s,' 'p);
end.
2)
3)var a,p,i:integer;
begin
readln(a);
p:=1;
for i:=1 to a do
p:=p*i;
writeln(p);
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
