Вопрос задан 14.01.2019 в 02:54.
Предмет Информатика.
Спрашивает Спартак Артём.
SOS, нужна помощь!!! Программисты помогите, пожалуйста, написать программу к задаче. Нужно
использовать while. Я школьник!
Ответы на вопрос
Отвечает Дегтярёва Ксения.
Var
i, //номер члена последовательности
n: integer; //длина последовательности
a: double; //заданное число
Begin
//--------------------------------------Ввод данных----------------------------------------------------
write('Введите длину последовательности: ');
read(n);
write('Введите a: ');
read(a);
//-----------------------------Вывод последовательности-------------------------------------------
i:=2;
write('Последовательность: ',1);
while i <= n do begin
write(' ',1+1/i:0:4); //4 - количество цифр после запятой, если нужна
большая точность можно увеличить это число
i:=i+1;
end;
writeln();
//------------------------------Вывод требуемых чисел----------------------------------------------
write('Числа меньше а: ');
i:=2;
if a > 1 then write(1);
while i <= n do begin
if 1+1/i < a then write(' ',1+1/i:0:4); //если i-й член последовательности < a,
то печатаем это число
i:=i+1; //переходим к следующему числу в последовательности
end;
End.
i, //номер члена последовательности
n: integer; //длина последовательности
a: double; //заданное число
Begin
//--------------------------------------Ввод данных----------------------------------------------------
write('Введите длину последовательности: ');
read(n);
write('Введите a: ');
read(a);
//-----------------------------Вывод последовательности-------------------------------------------
i:=2;
write('Последовательность: ',1);
while i <= n do begin
write(' ',1+1/i:0:4); //4 - количество цифр после запятой, если нужна
большая точность можно увеличить это число
i:=i+1;
end;
writeln();
//------------------------------Вывод требуемых чисел----------------------------------------------
write('Числа меньше а: ');
i:=2;
if a > 1 then write(1);
while i <= n do begin
if 1+1/i < a then write(' ',1+1/i:0:4); //если i-й член последовательности < a,
то печатаем это число
i:=i+1; //переходим к следующему числу в последовательности
end;
End.
Отвечает Алексеева Вика.
var n: integer;
a: real;
arr: array[1..999999] of real;
begin
write('Введите длину последовательности: ');
read(n);
write('Введите a: ');
read(a);
for var i := 1 to n do begin
if i = 1 then
arr[i] := 1
else
arr[i] := 1 + 1/i;
if arr[i] < a then
writeln(arr[i]);
end;
end.
a: real;
arr: array[1..999999] of real;
begin
write('Введите длину последовательности: ');
read(n);
write('Введите a: ');
read(a);
for var i := 1 to n do begin
if i = 1 then
arr[i] := 1
else
arr[i] := 1 + 1/i;
if arr[i] < a then
writeln(arr[i]);
end;
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
