Вопрос задан 22.04.2018 в 08:47.
Предмет Информатика.
Спрашивает Артемьев Матвей.
№1 Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры
положительных целых чисел а и Ь хотя бы одно четное. Была написана следующая программа: • var a, b: integer; • begin • readln(a, b); • a := a mod 2; • if a > 0 then b := b mod 2; • if b > 0 then • writeln ('четных чисел нет') • else • writeln ('четное число есть'); • end. Доработайте эту программу таким образом, чтобы задача решалась верно. №2 С клавиатуры вводится трёхзначное число. Нужно вывести ответ «Да», если все его цифры четные, и ответ «Нет» в остальных случаях. Если введено не трёхзначное число, должно быть выведено сообщение «Неверное число».Ответы на вопрос
Отвечает Данильченко Влад.
N1
var a, b: integer;
• begin
• readln(a, b);
• a := a mod 2;
b := b mod 2;
• if (b > 0) and (a > 0) then
• writeln ('четных чисел нет')
• else
• writeln ('четное число есть');
end.
N2
#include <iostream>
using namespace std;
int main()
{
int a;
cin >> a;
if(a < 100 || a > 999) cout << "Неверное число" << endl;
else
{
int a1 = a/100;
int a2 = (a/10)%10;
int a3 = a%10;
if(a1%2==a2%2==a3%2==0) cout << "Да" << endl;
else cout << "Нет" << endl;
}
return 0;
}
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
