Вопрос задан 12.01.2019 в 05:48. Предмет Информатика. Спрашивает Яковлев Андрей.

В двумерном массиве найтив двумерном массиве найти минимальные и максимальные элементы и вычислить

их сумму произведение и разность (Составить программу)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Стрілець Віталій.
Program Pr;
Var
a : array [1..100, 1..100] of integer;
i, max, min, j, n: integer;
Begin
cls;
read(n);
min := 100000;
max := -100000;
for i := 1 to n do 
   for j := 1 to n do     
       begin           
           read(a[i,j]);           
           if (a[i,j] > max) then             
               max := a[i,j];           
          if (a[i,j] < min) then             
               min := a[i,j];     
        end;     
 writeln ('Сумма = ', min + max);
writeln ('Разность = ', max - min);
writeln ('Произведение = ', max * min);

End.
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос