Вопрос задан 11.01.2019 в 22:45.
Предмет Информатика.
Спрашивает Гибельгаус Катя.
Напишите программу. Определить номер подъезда и этаж квартиры по её номеру, если известна этажность
дома и количество квартир на лестничной площадкеОтветы на вопрос
Отвечает Новосельский Кирилл.
Program P1;
var z,x,y,p,e:integer;
begin
write('Количество этажей = '); readln(x);
write('Количество квартир на лестничной площадке = ');
readln(y);
write('Номер квартиры = '); readln(z);
p:=(z-1) div (x*y)+1;
e:=((z-(p-1)*x*y)-1) div y +1;
writeln('Квартира ',z,' находится в ',p,' подъезде на ',e,' этаже');
end.
Пример:
Количество этажей = 9
Количество квартир на лестничной площадке = 4
Номер квартиры = 67
Квартира 67 находится в 2 подъезде на 8 этаже
var z,x,y,p,e:integer;
begin
write('Количество этажей = '); readln(x);
write('Количество квартир на лестничной площадке = ');
readln(y);
write('Номер квартиры = '); readln(z);
p:=(z-1) div (x*y)+1;
e:=((z-(p-1)*x*y)-1) div y +1;
writeln('Квартира ',z,' находится в ',p,' подъезде на ',e,' этаже');
end.
Пример:
Количество этажей = 9
Количество квартир на лестничной площадке = 4
Номер квартиры = 67
Квартира 67 находится в 2 подъезде на 8 этаже
Топ вопросов за вчера в категории Информатика
Информатика 31
Информатика 36
Информатика 24
Информатика 43
Информатика 18
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
