Вопрос задан 09.01.2019 в 04:05.
Предмет Информатика.
Спрашивает Горборуков Никита.
Составить программу, которая проверяла бы, не приводит ли суммирование двух целых чисел А и В к
переполнению (т.е. к результату большему чем 32 767). Если будет переполнение, то сообщить об этом, иначе вывести сумму этих чисел.Ответы на вопрос
Отвечает Куга Диана.
Var
a, b, s : Integer;
begin
Write('введите a= ');
readln(a);
Write('введите b= ');
readln(b);
S:=a+b;
if s<32767 then writeln(s) else writeln('произошло переполнение');
end.
a, b, s : Integer;
begin
Write('введите a= ');
readln(a);
Write('введите b= ');
readln(b);
S:=a+b;
if s<32767 then writeln(s) else writeln('произошло переполнение');
end.
Отвечает Макеев Кирилл.
Int A,B,Summ
A+B=Summ
if (Summ>32767) cout>>"Переполнение"
else cout>>"Summ"
A+B=Summ
if (Summ>32767) cout>>"Переполнение"
else cout>>"Summ"
Топ вопросов за вчера в категории Информатика
Информатика 18
Информатика 34
Информатика 19
Информатика 26
Информатика 20
Информатика 33
Информатика 31
Информатика 21
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
