Вопрос задан 21.04.2018 в 04:37.
Предмет Информатика.
Спрашивает Корчевський Саша.
Нужно написать программу на языке pascal.на вход подается 2 слова.и программа должна вывести буквы
которые встречаются только в одном слове,но не в обоих например: есть слова процессор и информация. результат:п е ф м а я с нОтветы на вопрос
Отвечает Кузменкова Дарья.
PascalABC.Net
var
sc1,sc2:set of char;
s1,s2:string;
c:char;
i:integer;
begin
Write('Введите первое слово: '); Readln(s1);
Write('Введите второе слово: '); Readln(s2);
sc1:=[]; sc2:=[];
for i:=1 to Length(s1) do Include(sc1,s1[i]);
for i:=1 to Length(s2) do Include(sc2,s2[i]);
foreach c in sc1+sc2-(sc1*sc2) do Write(c,' ')
end.
Тестовое решение:
Введите первое слово: процессор
Введите второе слово: информация
п я н м ф а е с и
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
