
Вопрос задан 07.01.2019 в 10:41.
Предмет Информатика.
Спрашивает Данилова Евгения.
Напишите программу подсчета произведения всех отрицательных элементов заданного целочисленного
массива размером 30 элементов, в предположении, что в массиве есть хотя бы 1 отрицательный элемент (Паскаль)

Ответы на вопрос

Отвечает Деордияшенко Влад.
Var mas30: array [1..30] of integer;
var i, proz: integer;
begin
proz:=1;
for i:=1 to 30 do begin mas30[i]:=-5+random (11); //Заполнение массива
write (mas30[i], ' '); //вывод значений массива
end;
writeln;
for i:=1 to 30 do if mas30[i]<0 then proz:=proz*mas30[i]; //Подсчет произведения отриц элементов
writeln (proz);
end.
var i, proz: integer;
begin
proz:=1;
for i:=1 to 30 do begin mas30[i]:=-5+random (11); //Заполнение массива
write (mas30[i], ' '); //вывод значений массива
end;
writeln;
for i:=1 to 30 do if mas30[i]<0 then proz:=proz*mas30[i]; //Подсчет произведения отриц элементов
writeln (proz);
end.


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili