Вопрос задан 06.01.2019 в 20:59.
Предмет Информатика.
Спрашивает Куттыбай Алия.
Написать программу в PascalABC.NETзадание:с клавиатуры вводятся 3 числа.найти среднее
арифметическое двух больших и двух меньших.Ответы на вопрос
Отвечает Верталь Дарья.
по нубски правдо очень проверить не забудь)
var
a,n,c:integer;
x,y:real;
begin
readln(a);
readln(n);
readln(c);
if ((a > n) and (n > c)) then begin
x:=(a+n)/2;
y:=(n+c)/2;
end else if((n > a) and (a > c)) then begin
x:=(a+n)/2;
y:=(a+c)/2;
end else if((c > a) and (a > n)) then begin
x:=(a+c)/2;
y:=(a+n)/2;
end else if((c > n) and (n > c)) then begin
x:=(c+n)/2;
y:=(n+c)/2;
end else if((n > c) and (c > a)) then begin
x:=(c+n)/2;
y:=(a+c)/2;
end else if((a > c) and (c > n)) then begin
x:=(c+a)/2;
y:=(n+c)/2;
end else if((c > n) and (n > a)) then begin
x:=(c+n)/2;
y:=(n+a)/2;
end;
write('наибольшее: ',x,' наименьшее: ',y);
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
