Вопрос задан 20.04.2018 в 06:29.
Предмет Информатика.
Спрашивает Кораблёв Евгений.
1) составить программу на паскале. вычесления расстояния между касательной и секущей если в
окружности радиуса r проведена хорда длиной r/2 через один конец которой проведена касательная к окружности а через другой-секущая паралельная касательнойи то же самое вариант-19))
Ответы на вопрос
Отвечает Паршина Марина.
Это мы не проходили,
Это нам не задавали!
А квадратное уравнение решаемо =)
var a, b, c, d, x1, x2: real;
begin
readln(a, b, c);
d := b * b - 4 * a * c;
if d >= 0 then begin
if d <> 0 then begin
x1 := (-b + sqrt(d)) / 2 * a;
x2 := (-b - sqrt(d)) / 2 * a;
writeln('x1 = ', x1:4:2, ', x2 = ', x2:4:2)
end
else begin
x1 := -(b / 2 * a);
writeln('x = ', x1:4:2)
end
end
else begin
writeln('Нет решения');
end
end.
Удачи тебе с остальными)
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 37
Информатика 11
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 30
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
