Вопрос задан 02.01.2019 в 08:43.
Предмет Информатика.
Спрашивает Davletov Alihan.
Составить программу, которая запрашивая вес покупки в граммах переводило в кг
Ответы на вопрос
Отвечает Иваненко Тёма.
Program z1;
var a,b:real;
f:longint;
begin
writeln('Ââåäèòå Г¬Г*Г±Г±Гі Гў ГЄГЈ:');
read(a);
writeln('Ââåäèòå åäèГ*ГЁГ¶Гі âûâîäГ*:');
writeln('1 - ìèëëèãðГ*ìì');
writeln('2 - ГЈГ°Г*ìì');
writeln('3 - êèëîãðГ*ìì');
writeln('4 - Г¶ГҐГ*ГІГ*ГҐГ°');
writeln('5 - ГІГ®Г*Г*Г*');
read(f); if (f<1) or (f>6) then begin writeln('Ïîâòîðèòå ââîä');
read(f);
end;
if f=1 then begin
b:=a*1000000;
write(a,' ГЄГЈ=',' ',b,' ','ìèëëèãðГ*ìì');
end;
if f=2 then begin
b:=a*1000;
write(a,' ГЄГЈ=',' ',b,' ','ГЈГ°Г*ìì');
end; if f=3 then begin
b:=a;
write(a,' ГЄГЈ =',' ',b,' ','êèëîãðГ*ìì');
end; if f=4 then begin
b:=a/100;
write(a,' ГЄГЈ=',' ',b,' ','Г¶ГҐГ*òðîâ');
end;
if f=5 then begin
b:=a/1000;
write(a,' ГЄГЈ=',' ',b,' ','ГІГ®Г*Г*');
end;
writeln('ÏðîãðГ*ììГ* Г§Г*âåðøåГ*Г*');
end.
var a,b:real;
f:longint;
begin
writeln('Ââåäèòå Г¬Г*Г±Г±Гі Гў ГЄГЈ:');
read(a);
writeln('Ââåäèòå åäèГ*ГЁГ¶Гі âûâîäГ*:');
writeln('1 - ìèëëèãðГ*ìì');
writeln('2 - ГЈГ°Г*ìì');
writeln('3 - êèëîãðГ*ìì');
writeln('4 - Г¶ГҐГ*ГІГ*ГҐГ°');
writeln('5 - ГІГ®Г*Г*Г*');
read(f); if (f<1) or (f>6) then begin writeln('Ïîâòîðèòå ââîä');
read(f);
end;
if f=1 then begin
b:=a*1000000;
write(a,' ГЄГЈ=',' ',b,' ','ìèëëèãðГ*ìì');
end;
if f=2 then begin
b:=a*1000;
write(a,' ГЄГЈ=',' ',b,' ','ГЈГ°Г*ìì');
end; if f=3 then begin
b:=a;
write(a,' ГЄГЈ =',' ',b,' ','êèëîãðГ*ìì');
end; if f=4 then begin
b:=a/100;
write(a,' ГЄГЈ=',' ',b,' ','Г¶ГҐГ*òðîâ');
end;
if f=5 then begin
b:=a/1000;
write(a,' ГЄГЈ=',' ',b,' ','ГІГ®Г*Г*');
end;
writeln('ÏðîãðГ*ììГ* Г§Г*âåðøåГ*Г*');
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
