Вопрос задан 01.01.2019 в 09:04.
Предмет Информатика.
Спрашивает Мирная Катя.
Написать программу на языке Pascal. Даны действительные числа а₁, а₂, ..., а₂₀. Вычислить их сумму.
Ответы на вопрос
Отвечает Занковец Максим.
Const
N = 20;
Var
A:array[1..N] of real;
i:integer;
S:real;
Begin
Randomize;
S:=0;
Write('Исходный массив A(',N,'):');
For i:= 1 to N do
Begin
A[i]:=random*(N*2+1)-N;
Write(' ',A[i]:0:3);
S:=S+A[i];
End;
WriteLn;
WriteLn('S = ',S);
End.
N = 20;
Var
A:array[1..N] of real;
i:integer;
S:real;
Begin
Randomize;
S:=0;
Write('Исходный массив A(',N,'):');
For i:= 1 to N do
Begin
A[i]:=random*(N*2+1)-N;
Write(' ',A[i]:0:3);
S:=S+A[i];
End;
WriteLn;
WriteLn('S = ',S);
End.
Топ вопросов за вчера в категории Информатика
Информатика 33
Информатика 32
Информатика 51
Информатика 94
Информатика 36
Информатика 22
Информатика 36
Информатика 12
Информатика 13
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
