
Вопрос задан 31.12.2018 в 20:39.
Предмет Информатика.
Спрашивает Романова Софья.
Составить программу на языке Pascal. Дано: а1, а2, а3, - производное. Найти: min


Ответы на вопрос

Отвечает Дубровский Артём.
Program bit;
var m,a1,a2,a3:
integer;
begin
writeln('введите три числа');
readln(a1,a2,a3);
if (a1<a2) and (a1<a3) then m:=a1;
if (a2<a1) and (a2<a3) then m:=a2;
if (a3<a1) and (a3<a2) then m:=a3;
if (a1=a2) and (a1=a3) then
writeln('они равны')
else writeln('меньшее из трёх ',m);
end.
var m,a1,a2,a3:
integer;
begin
writeln('введите три числа');
readln(a1,a2,a3);
if (a1<a2) and (a1<a3) then m:=a1;
if (a2<a1) and (a2<a3) then m:=a2;
if (a3<a1) and (a3<a2) then m:=a3;
if (a1=a2) and (a1=a3) then
writeln('они равны')
else writeln('меньшее из трёх ',m);
end.



Отвечает Алтухова Мирослава.
Var a1, a2, a3, min : integer;
begin
readln(a1, a2, a3);
min := a1;
if min > a2 then min := a2;
if min > a3 then min := a3;
writeln(min);
end.
begin
readln(a1, a2, a3);
min := a1;
if min > a2 then min := a2;
if min > a3 then min := a3;
writeln(min);
end.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili